PHPEclipse 1.2.0 for Eclipse 3.2.2 on Ubuntu Gutsy

[digg=http://digg.com/programming/Making_PHPEclipse_for_Ubuntu_work_in_Gutsy]

For those having problems with more recent versions of Eclipse, I
recommend reading my other article on this blog and more importantly
the header note for a non-Ubuntu solution.

To make a long story short, it doesn’t work (at least in this versions combination)…

I’ve tried it many time with any combination of attached plugins installed or not, with GCJ instead of Java 1.6, but it always coms out with an error when trying to opening any PHP file. The error recommends checking the logs. The logs, in turn, mention that something is wrong with JFace

!ENTRY org.eclipse.jface 4 2 2008-02-15 15:34:07.081
!MESSAGE Problems occurred when invoking code from plug-in: “org.eclipse.jface”.
!STACK 0
java.lang.NoClassDefFoundError: org/eclipse/ui/ide/FileStoreEditorInput

So in the end I searched the net a little bit and decided to downgrade a little bit to PHPEclipse 1.1.8, which following a few comments on PHPEclipse.net had quite a lot of bugs that were fixed in 1.2.0.

Well, guess what? It works perfectly well. Of course, it doesn’t have fancy stuff like the XDebug plugin, but honestly this one isn’t too well documented, which makes it a bit useless in the end.

It's only fair to share...Share on FacebookShare on Google+Tweet about this on TwitterShare on LinkedInShare on TumblrEmail this to someone

Leave a Reply

Your email address will not be published. Required fields are marked *