Si no arranca eclipse

Espero que les sirva este post para los que usan eclipse.
Si no arranca su eclipse por que hicieron alguna actualizacion u otro, podrian probar siguiendo estos pasos de NUESTRO AMIGO (slack).

lunes 13 de abril de 2009
Error al arrancar Eclipse
Hola, en algunos casos el sistema operativo se marea con la jvm que ocupa, esto generalmente ocurre cuando hacemos alguna actualización de algún paquete con el gestor o comando alternatives.
Y cuando queremos arrancar eclipse desde el lanzador del escritorio, simplemente no lo abre. y comenzamos con cuestionamientos… jajajaj…, en este caso lo logico es que queramos abrirlo por consola con el comando

slack@zion:programas/eclipse$ ./eclipse
LOG: [0xb7eb66b0] exception thrown while VM is initializing:
LOG: [0xb7eb66b0] NULL: java.lang.Object
LOG: [0xb7eb66b0] Aborting…
Aborted

desplegando el mensaje de error que se ve, lo bueno de esto es que existe una rapida solución.

En la misma consola ejecutamos el siguiente comando para comprobar las jvm disponibles para usar en el sistema,

slack@zion:~/programas/eclipse$ sudo update-alternatives –config java
[sudo] password for slack:

Hay 2 alternativas que proveen `java’.

Selección Alternativa
———————————————–
1 /usr/lib/jvm/java-1.5.0-sun/jre/bin/java
*+ 2 /usr/lib/jvm/java-6-cacao/jre/bin/java

Pulse para mantener el valor por omisión [*] o pulse un número de selección: 1
Se utiliza `/usr/lib/jvm/java-1.5.0-sun/jre/bin/java’ para proporcionar `java’.

Luego comprobamos que la opcion seleccinada sea la que tome el sistema como version de uso para java.

slack@zion:~/programas/eclipse$ java -version
java version “1.5.0_16”
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_16-b02)
Java HotSpot(TM) Server VM (build 1.5.0_16-b02, mixed mode)

Con esto debieramos tener solucionado el tema de incompatibilidad de jvm con eclipse, al menos.

Saludos y Suerte !!

Compartelo en tus redes socialesShare on Facebook
Facebook
Tweet about this on Twitter
Twitter
Email this to someone
email
Share on Tumblr
Tumblr
Share on LinkedIn
Linkedin

2 Comments

  1. Muchas gracias por esta solucion, yo actualize a Ubuntu 9.04, y de pronto no arrancaba mi eclipse, intente reinstalarlo, sabiendo que esto conllevaba a volver a descargar los plugins de php, asi que descargue el Eclipse galileo, pero ocurria lo mismo no arrancaba si quiera el Eclipse, hize esto y funciono

    Gracias Arhur

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos necesarios están marcados *