Class ‘imagick’ not found

Este articulo explica (en Inglés) como arreglar el problema del paquete Imagick para PHP5 en Ubuntu Feisty. Traducción sigue:

“He probado usar Image Magick con PHP hace poco por una Ubuntu Feisty, y mientras pensaba que tenía el paquete requisito: ‘php5-imagick’ instalado, y actualizé mi php.ini con imagick.so, me seguía dando el error Class ‘Imagick’ not found. Aquí explico como lo arregle finalmente.

La idea es de regresar a la buena y antigua instalación de PECL:

sudo aptitude install make php5-dev php-pear
sudo aptitude remove php5-imagick
sudo aptitude install libmagick9-dev
sudo pecl install imagick
sudo /etc/init.d/apache2 restart

No se olvide poner el imagick.so en su php.ini!
Bueno, esto funcionó para mi. No necesidad para un largo artículo esta vez, pero esto podría ayudar otros teniendo el mismo problema.

Gracias a Kevin para su artículo. Si nos ayudó! Cabe mencionar que el error sigue ocurriendo en una Ubuntu Hardy Heron (8.04).

It's only fair to share...Share on FacebookShare on Google+Tweet about this on TwitterShare on LinkedInShare on TumblrEmail this to someone
Posted in:

2 Comments

Leave a Reply

Your email address will not be published. Required fields are marked *